MI 3.8 - Crashes during test plan at 192kHz

MI 3.8 - Crashes during test plan at 192kHz

Postby RJA4000 » Fri Aug 02, 2019 9:18 pm

Hello

I ran test plans at 48kHz without issue.
Now I try a test plan for evaluating THD vs frequency, at 24 bits 192kHz and it crashes randomly (at a variable step of the test plan) during test plan execution
(Note: This happens with an FFT window size of 262144)

Eventvwr error message:
Faulting application name: MIs.exe, version: 3.8.5.2, time stamp: 0x5c2ec2f6
Faulting module name: SoundCardASIODAQO.dll, version: 3.8.0.0, time stamp: 0x5bd0062c
Exception code: 0xc0000005
Fault offset: 0x00007574
Faulting process id: 0x3c84
Faulting application start time: 0x01d5491fb2b39922
Faulting application path: C:\VIRTINS Multi-Instrument 3.8\MIs.exe
Faulting module path: C:\VIRTINS Multi-Instrument 3.8\SoundCardASIODAQO.dll
Report Id: aec9598d-cb3a-42f7-b0eb-bbf108108b8e
Faulting package full name:
Faulting package-relative application ID:

DAQ:
Sound card ASIO
ASIO Madiface USB (RME ADI-2 Pro FS)
Channels Analog 1+2
Buffersize 4294967295


Also add manual crash at same settings:
Faulting application name: MIs.exe, version: 3.8.5.2, time stamp: 0x5c2ec2f6
Faulting module name: MIs.exe, version: 3.8.5.2, time stamp: 0x5c2ec2f6
Exception code: 0xc000041d
Fault offset: 0x00151c76
Faulting process id: 0x3a00
Faulting application start time: 0x01d54933df1c723f
Faulting application path: C:\VIRTINS Multi-Instrument 3.8\MIs.exe
Faulting module path: C:\VIRTINS Multi-Instrument 3.8\MIs.exe
Report Id: 25b60620-0c5a-4d21-9037-47c193f15d8f
Faulting package full name:
Faulting package-relative application ID:
RJA4000
 
Posts: 27
Joined: Sun Jul 28, 2019 2:28 am

Re: MI 3.8 - Crashes during test plan at 192kHz

Postby VirtinsTech » Sun Aug 04, 2019 11:22 pm

We have tested with some ASIO drivers at 192kHz both manually outside Device Test Plan and automatically inside Device Test Plan. So far we did not encounter any problem. The ASIO buffer size was set to "MAX" through [Setting]>[Display]>"ASIO Buffer Size" during the tests. This is actually the default setting. The software needs a not-too-small ASIO buffer size to work efficiently.

For your cases, if crashes still occur after setting ASIO buffer size to "MAX", try to set the Trigger Mode to "Auto" instead of "Normal" or "Single" and see whether it helps. In Device Test Plan, for SIO and STI instructions, tick the "No Trigger" option.

Also, in Device Test Plan, if possible, try not to use LDP inside an endless loop unnecessarily.

If you have a particular Panel Setting File or DTP file that will cause crash at 192kHz, you may upload it here. We can then test it on our side.
VirtinsTech
Site Admin
 
Posts: 146
Joined: Tue Oct 01, 2013 3:06 pm

Re: MI 3.8 - Crashes during test plan at 192kHz

Postby RJA4000 » Tue Aug 13, 2019 12:39 am

Hi

I don't do a lot of 192kHz sampling yet.
Buffer size seems to be at max value. At least it is set very high.
I ugraded the RME ASIO driver.
Maybe that will help...
RJA4000
 
Posts: 27
Joined: Sun Jul 28, 2019 2:28 am

Re: MI 3.8 - Crashes during test plan at 192kHz

Postby RJA4000 » Sun Sep 29, 2019 8:53 pm

Hi

Much more stable since RME update.
RJA4000
 
Posts: 27
Joined: Sun Jul 28, 2019 2:28 am


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 3 guests